import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "root\\";
final String string = "root 16899 0.0 0.0 32776 1992 pts/8 S 17:49 0:00 /usr/sbin/pppd \n"
+ "460800 modem crtscts defaultroute usehostname -detach user entelpcs noipdefault call wvdial usepeerdns idle 0 logfd 8\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}