// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"root\").unwrap();
let string = "root 16899 0.0 0.0 32776 1992 pts/8 S 17:49 0:00 /usr/sbin/pppd
460800 modem crtscts defaultroute usehostname -detach user entelpcs noipdefault call wvdial usepeerdns idle 0 logfd 8
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}