import re
regex = re.compile(r"root\\")
test_str = ("root 16899 0.0 0.0 32776 1992 pts/8 S 17:49 0:00 /usr/sbin/pppd \n"
"460800 modem crtscts defaultroute usehostname -detach user entelpcs noipdefault call wvdial usepeerdns idle 0 logfd 8\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")