const regex = /root\/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('root\\', '')
const str = `root 16899 0.0 0.0 32776 1992 pts/8 S 17:49 0:00 /usr/sbin/pppd
460800 modem crtscts defaultroute usehostname -detach user entelpcs noipdefault call wvdial usepeerdns idle 0 logfd 8
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}