using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<exprs> (?&expr)(\s+(?&bool)\s+((?&expr)|\(\s*(?&exprs)\s*\)))* )
(?<expr> (?&valleft)\s?(?&comp)\s?(?&valright) )
(?<comp> ((!=)|(==)|(<=)|(>=)|(<)|(>)){1} )
(?<valleft> (?¬)[\w\.]+ )
(?<valright> [\w\.]+ )
(?<bool> (and|or) )
(?<not> (not\s+)?)
)
(?&exprs)";
string input = @"common.test == 1 or ts==12 and (nlabla<=10 or er==22 or blabl==11 and ere==2 and (bbbb==21 and gg==12) and test==13)";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}