import re
regex = re.compile(r"""
(?(DEFINE)
(?<exprs> (?&expr)(\s+(?&bool)\s+((?&expr)|\(\s*(?&exprs)\s*\)))* )
(?<expr> (?&valleft)\s?(?&comp)\s?(?&valright) )
(?<comp> ((!=)|(==)|(<=)|(>=)|(<)|(>)){1} )
(?<valleft> (?¬)[\w\.]+ )
(?<valright> [\w\.]+ )
(?<bool> (and|or) )
(?<not> (not\s+)?)
)
(?&exprs)
""", flags=re.VERBOSE | re.MULTILINE)
test_str = "common.test == 1 or ts==12 and (nlabla<=10 or er==22 or blabl==11 and ere==2 and (bbbb==21 and gg==12) and test==13)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")