import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<exprs> (?&expr)(\\s+(?&bool)\\s+((?&expr)|\\(\\s*(?&exprs)\\s*\\)))* )\n"
+ " (?<expr> (?&valleft)\\s?(?&comp)\\s?(?&valright) )\n"
+ " (?<comp> ((!=)|(==)|(<=)|(>=)|(<)|(>)){1} )\n"
+ " (?<valleft> (?¬)[\\w\\.]+ )\n"
+ " (?<valright> [\\w\\.]+ )\n"
+ " (?<bool> (and|or) )\n"
+ " (?<not> (not\\s+)?)\n"
+ ")\n"
+ "(?&exprs)";
final String string = "common.test == 1 or ts==12 and (nlabla<=10 or er==22 or blabl==11 and ere==2 and (bbbb==21 and gg==12) and test==13)";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}