#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((apple|orange|plum|pear|chery)(?: |$))+)$"
Local $sString = "apple orange plum" & @CRLF & _
"apple grape plum" & @CRLF & _
"apple chery" & @CRLF & _
"orange" & @CRLF & _
"apples" & @CRLF & _
"appleplum" & @CRLF & _
"chery apple apple apple chery"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")