// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((apple|orange|plum|pear|chery)(?: |$))+)$").unwrap();
let string = "apple orange plum
apple grape plum
apple chery
orange
apples
appleplum
chery apple apple apple chery";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}