using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((apple|orange|plum|pear|chery)(?: |$))+)$";
string input = @"apple orange plum
apple grape plum
apple chery
orange
apples
appleplum
chery apple apple apple chery";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}