$re = '/^(((apple|orange|plum|pear|chery)(?: |$))+)$/m';
$str = 'apple orange plum
apple grape plum
apple chery
orange
apples
appleplum
chery apple apple apple chery';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);