package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((apple|orange|plum|pear|chery)(?: |$))+)$`)
var str = `apple orange plum
apple grape plum
apple chery
orange
apples
appleplum
chery apple apple apple chery`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}