package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?<Address>(?<Protocol>https?:\/\/)?(?<Subdomain>\w*\.)?(?<Domain>(?:[a-z0-9\-]{2,})\.(?:[^\s\/\.]{2,}))(?<Path>\/[^\s\?]*)?(?<Params>(?:\?|\#)[^\s\/\?\:]*)?)`)
var str = `https://bosym.de/index.php?s#instagram
https://www.google.de/?gws_rd=ssl
https://soundcloud.com/mcmainiac
www.wetter.info
http://www.web.ninja/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}