import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Address>(?<Protocol>https?:\\/\\/)?(?<Subdomain>\\w*\\.)?(?<Domain>(?:[a-z0-9\\-]{2,})\\.(?:[^\\s\\/\\.]{2,}))(?<Path>\\/[^\\s\\?]*)?(?<Params>(?:\\?|\\#)[^\\s\\/\\?\\:]*)?)";
final String string = "https://bosym.de/index.php?s#instagram\n"
+ "https://www.google.de/?gws_rd=ssl\n"
+ "https://soundcloud.com/mcmainiac\n"
+ "www.wetter.info\n"
+ "http://www.web.ninja/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}