// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?<Address>(?<Protocol>https?:\/\/)?(?<Subdomain>\w*\.)?(?<Domain>(?:[a-z0-9\-]{2,})\.(?:[^\s\/\.]{2,}))(?<Path>\/[^\s\?]*)?(?<Params>(?:\?|\#)[^\s\/\?\:]*)?)").unwrap();
let string = "https://bosym.de/index.php?s#instagram
https://www.google.de/?gws_rd=ssl
https://soundcloud.com/mcmainiac
www.wetter.info
http://www.web.ninja/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}