const regex = /(?<Address>(?<Protocol>https?:\/\/)?(?<Subdomain>\w*\.)?(?<Domain>(?:[a-z0-9\-]{2,})\.(?:[^\s\/\.]{2,}))(?<Path>\/[^\s\?]*)?(?<Params>(?:\?|\#)[^\s\/\?\:]*)?)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<Address>(?<Protocol>https?:\\\/\\\/)?(?<Subdomain>\\w*\\.)?(?<Domain>(?:[a-z0-9\\-]{2,})\\.(?:[^\\s\\\/\\.]{2,}))(?<Path>\\\/[^\\s\\?]*)?(?<Params>(?:\\?|\\#)[^\\s\\\/\\?\\:]*)?)', 'gi')
const str = `https://bosym.de/index.php?s#instagram
https://www.google.de/?gws_rd=ssl
https://soundcloud.com/mcmainiac
www.wetter.info
http://www.web.ninja/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}