#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^a-z'"*&<>\/\n]+$"
Local $sString = "Valid examples:" & @CRLF & _
"" & @CRLF & _
"SITE 10" & @CRLF & _
"A23 - FLATS 12B RANGE AND ALLOWANCE PITCH." & @CRLF & _
"2 - 9 GUARDSPACE AVENUE." & @CRLF & _
"Invalid:" & @CRLF & _
"" & @CRLF & _
"site 10" & @CRLF & _
"A23 / FLATS 12B RANGE AND ALLOWANCE PITCH" & @CRLF & _
"2 & 9 GUARDSPACE AVENUE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")