re = /^[^a-z'"*&<>\/\n]+$/m
str = 'Valid examples:
SITE 10
A23 - FLATS 12B RANGE AND ALLOWANCE PITCH.
2 - 9 GUARDSPACE AVENUE.
Invalid:
site 10
A23 / FLATS 12B RANGE AND ALLOWANCE PITCH
2 & 9 GUARDSPACE AVENUE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end