const regex = /^[^a-z'"*&<>\/\n]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^a-z\'"*&<>\\\/\\n]+$', 'gm')
const str = `Valid examples:
SITE 10
A23 - FLATS 12B RANGE AND ALLOWANCE PITCH.
2 - 9 GUARDSPACE AVENUE.
Invalid:
site 10
A23 / FLATS 12B RANGE AND ALLOWANCE PITCH
2 & 9 GUARDSPACE AVENUE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}