using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^a-z'""*&<>\/\n]+$";
string input = @"Valid examples:
SITE 10
A23 - FLATS 12B RANGE AND ALLOWANCE PITCH.
2 - 9 GUARDSPACE AVENUE.
Invalid:
site 10
A23 / FLATS 12B RANGE AND ALLOWANCE PITCH
2 & 9 GUARDSPACE AVENUE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}