#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:https?:\/\/)?(?:www\.)?(?:\S+)?(?:\.\S+)?\.(?:com|io)(?:\/\S+)?(?:\?[\S]+)?)"
Local $sString = "test.com" & @CRLF & _
"https://test.com" & @CRLF & _
"www.test.com" & @CRLF & _
"test.com/2022/test-test/123x456?test&test" & @CRLF & _
"test.com?test&123" & @CRLF & _
"subdomain.test.com?test&123" & @CRLF & _
"www.subdomain.test.com?test&123" & @CRLF & _
"" & @CRLF & _
"test.io" & @CRLF & _
"https://test.io" & @CRLF & _
"www.test.io" & @CRLF & _
"test.io/2022/test-test/123x456?test&test" & @CRLF & _
"test.io?test&123" & @CRLF & _
"subdomain.test.io?test&123" & @CRLF & _
"www.subdomain.test.io?test&123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"test." & @CRLF & _
"test.." & @CRLF & _
"test..." & @CRLF & _
"test...." & @CRLF & _
".test" & @CRLF & _
"..test" & @CRLF & _
"...test" & @CRLF & _
"....test" & @CRLF & _
"test.test" & @CRLF & _
"test..test" & @CRLF & _
"test...test" & @CRLF & _
"test....test" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")