import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:https?:\\/\\/)?(?:www\\.)?(?:\\S+)?(?:\\.\\S+)?\\.(?:com|io)(?:\\/\\S+)?(?:\\?[\\S]+)?)";
final String string = "test.com\n"
+ "https://test.com\n"
+ "www.test.com\n"
+ "test.com/2022/test-test/123x456?test&test\n"
+ "test.com?test&123\n"
+ "subdomain.test.com?test&123\n"
+ "www.subdomain.test.com?test&123\n\n"
+ "test.io\n"
+ "https://test.io\n"
+ "www.test.io\n"
+ "test.io/2022/test-test/123x456?test&test\n"
+ "test.io?test&123\n"
+ "subdomain.test.io?test&123\n"
+ "www.subdomain.test.io?test&123\n\n\n"
+ "test.\n"
+ "test..\n"
+ "test...\n"
+ "test....\n"
+ ".test\n"
+ "..test\n"
+ "...test\n"
+ "....test\n"
+ "test.test\n"
+ "test..test\n"
+ "test...test\n"
+ "test....test\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}