// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:https?:\/\/)?(?:www\.)?(?:\S+)?(?:\.\S+)?\.(?:com|io)(?:\/\S+)?(?:\?[\S]+)?)").unwrap();
let string = "test.com
https://test.com
www.test.com
test.com/2022/test-test/123x456?test&test
test.com?test&123
subdomain.test.com?test&123
www.subdomain.test.com?test&123
test.io
https://test.io
www.test.io
test.io/2022/test-test/123x456?test&test
test.io?test&123
subdomain.test.io?test&123
www.subdomain.test.io?test&123
test.
test..
test...
test....
.test
..test
...test
....test
test.test
test..test
test...test
test....test
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}