package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:https?:\/\/)?(?:www\.)?(?:\S+)?(?:\.\S+)?\.(?:com|io)(?:\/\S+)?(?:\?[\S]+)?)`)
var str = `test.com
https://test.com
www.test.com
test.com/2022/test-test/123x456?test&test
test.com?test&123
subdomain.test.com?test&123
www.subdomain.test.com?test&123
test.io
https://test.io
www.test.io
test.io/2022/test-test/123x456?test&test
test.io?test&123
subdomain.test.io?test&123
www.subdomain.test.io?test&123
test.
test..
test...
test....
.test
..test
...test
....test
test.test
test..test
test...test
test....test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}