import re
regex = re.compile(r"((?:https?:\/\/)?(?:www\.)?(?:\S+)?(?:\.\S+)?\.(?:com|io)(?:\/\S+)?(?:\?[\S]+)?)", flags=re.MULTILINE)
test_str = ("test.com\n"
"https://test.com\n"
"www.test.com\n"
"test.com/2022/test-test/123x456?test&test\n"
"test.com?test&123\n"
"subdomain.test.com?test&123\n"
"www.subdomain.test.com?test&123\n\n"
"test.io\n"
"https://test.io\n"
"www.test.io\n"
"test.io/2022/test-test/123x456?test&test\n"
"test.io?test&123\n"
"subdomain.test.io?test&123\n"
"www.subdomain.test.io?test&123\n\n\n"
"test.\n"
"test..\n"
"test...\n"
"test....\n"
".test\n"
"..test\n"
"...test\n"
"....test\n"
"test.test\n"
"test..test\n"
"test...test\n"
"test....test\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")