#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*\(\s*\)\s*\{(.*(return\s*\d*\s*;?)\s*)\}\s*;?"
Local $sString = "(){}" & @CRLF & _
"( ) { fsf }" & @CRLF & _
"() { return; }" & @CRLF & _
"() { return x; }" & @CRLF & _
"(){return 0;}" & @CRLF & _
"( ) { fsf return 0;}" & @CRLF & _
"( ) { return 0; }" & @CRLF & _
"(){ return; }" & @CRLF & _
"(){ if(x){ sdfsdf } return 0;}" & @CRLF & _
"(){ char x[20]; return };"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")