using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\(\s*\)\s*\{(.*(return\s*\d*\s*;?)\s*)\}\s*;?";
string input = @"(){}
( ) { fsf }
() { return; }
() { return x; }
(){return 0;}
( ) { fsf return 0;}
( ) { return 0; }
(){ return; }
(){ if(x){ sdfsdf } return 0;}
(){ char x[20]; return };";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}