import re
regex = re.compile(r"\s*\(\s*\)\s*\{(.*(return\s*\d*\s*;?)\s*)\}\s*;?")
test_str = ("(){}\n"
"( ) { fsf }\n"
"() { return; }\n"
"() { return x; }\n"
"(){return 0;}\n"
"( ) { fsf return 0;}\n"
"( ) { return 0; }\n"
"(){ return; }\n"
"(){ if(x){ sdfsdf } return 0;}\n"
"(){ char x[20]; return };")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")