package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\(\s*\)\s*\{(.*(return\s*\d*\s*;?)\s*)\}\s*;?`)
var str = `(){}
( ) { fsf }
() { return; }
() { return x; }
(){return 0;}
( ) { fsf return 0;}
( ) { return 0; }
(){ return; }
(){ if(x){ sdfsdf } return 0;}
(){ char x[20]; return };`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}