import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\(\\s*\\)\\s*\\{(.*(return\\s*\\d*\\s*;?)\\s*)\\}\\s*;?";
final String string = "(){}\n"
+ "( ) { fsf }\n"
+ "() { return; }\n"
+ "() { return x; }\n"
+ "(){return 0;}\n"
+ "( ) { fsf return 0;}\n"
+ "( ) { return 0; }\n"
+ "(){ return; }\n"
+ "(){ if(x){ sdfsdf } return 0;}\n"
+ "(){ char x[20]; return };";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}