using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\s+)(\w)";
string substitution = @"$1$2";
string input = @"U.S.A. is the country? i want to live in. if you please. yes. nope.
U.S.A. is the country? i want to live inc. if you pease. dope. yes.
U.S.A. is the country? i want to live Inc. if you pease. dope. yes.
u.s.w. and so on. a German abbreviation.
U.s.w. and so on. a German abbreviation.
// str
// .replace(
// (/(?<!\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\s+)(\w)/gi),
// (_, $1, $2) => $1 + $2.toUpperCase()
// );
// ... or ...
// str
// .replace(
// (/(?<!inc|pease|nope|U.S.A|u.s.w)([.?!]\s*)(\w)/gi),
// (_, $1, $2) => $1 + $2.toUpperCase()
// )
// .replace((/U\.S\.W\./g), 'u.s.w.');
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}