import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\\s+)(\\w)";
final String string = "U.S.A. is the country? i want to live in. if you please. yes. nope.\n"
+ "U.S.A. is the country? i want to live inc. if you pease. dope. yes.\n"
+ "U.S.A. is the country? i want to live Inc. if you pease. dope. yes.\n\n"
+ "u.s.w. and so on. a German abbreviation.\n"
+ "U.s.w. and so on. a German abbreviation.\n\n"
+ "// str\n"
+ "// .replace(\n"
+ "// (/(?<!\\b(?:inc|pease|nope|U.S.A|u.s.w))([.?!]\\s+)(\\w)/gi),\n"
+ "// (_, $1, $2) => $1 + $2.toUpperCase()\n"
+ "// );\n"
+ "// ... or ...\n"
+ "// str\n"
+ "// .replace(\n"
+ "// (/(?<!inc|pease|nope|U.S.A|u.s.w)([.?!]\\s*)(\\w)/gi),\n"
+ "// (_, $1, $2) => $1 + $2.toUpperCase()\n"
+ "// )\n"
+ "// .replace((/U\\.S\\.W\\./g), 'u.s.w.');\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}