using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{8}.csv";
string input = @"SEI_Crestline_Local_Position_Appraisal_05082015.csv
BB.upload.06102106.csv
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}