re = /[0-9]{8}.csv/
str = 'SEI_Crestline_Local_Position_Appraisal_05082015.csv
BB.upload.06102106.csv
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end