import Foundation
let pattern = #"[0-9]{8}.csv"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SEI_Crestline_Local_Position_Appraisal_05082015.csv
BB.upload.06102106.csv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}