$re = '/[0-9]{8}.csv/';
$str = 'SEI_Crestline_Local_Position_Appraisal_05082015.csv
BB.upload.06102106.csv
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);