#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+)\s*:\s*(["']).+\2,?"
Local $sString = "define({" & @CRLF & _
" key1: "some text: and more"," & @CRLF & _
" key2 : 'some text '," & @CRLF & _
" key3: ": more some text"," & @CRLF & _
" key4: 'some text:'" & @CRLF & _
"});" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")