import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s*:\\s*([\"']).+\\2,?";
final String string = "define({\n"
+ " key1: \"some text: and more\",\n"
+ " key2 : 'some text ',\n"
+ " key3: \": more some text\",\n"
+ " key4: 'some text:'\n"
+ "});\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}