re = /(\w+)\s*:\s*(["']).+\2,?/
str = 'define({
key1: "some text: and more",
key2 : \'some text \',
key3: ": more some text",
key4: \'some text:\'
});
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end