import re
regex = re.compile(r"(\w+)\s*:\s*([\"']).+\2,?")
test_str = ("define({\n"
" key1: \"some text: and more\",\n"
" key2 : 'some text ',\n"
" key3: \": more some text\",\n"
" key4: 'some text:'\n"
"});\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")