using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s*:\s*([""']).+\2,?";
string input = @"define({
key1: ""some text: and more"",
key2 : 'some text ',
key3: "": more some text"",
key4: 'some text:'
});
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}