#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "foo: \K.*"
Local $sString = "foo: bar"
Local $sSubst = "baz"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)