use strict;
my $str = 'foo: bar';
my $regex = qr/foo: \K.*/p;
my $subst = 'baz';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";