$re = '/foo: \K.*/';
$str = 'foo: bar';
$subst = "baz";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;