const regex = /foo: \K.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('foo: \\K.*', '')
const str = `foo: bar`;
const subst = `baz`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);