using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo: \K.*";
string substitution = @"baz";
string input = @"foo: bar";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}