import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-zA-Z])(\\n)";
final String string = "Chapter 1\n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipisci\n"
+ "ng elit, sed do eiusmod tempor incididunt ut la\n"
+ "bore et dolore magna aliqua. Ut enim ad minim ve\n"
+ "niam, quis nostrud exercitation ullamco labo ris\n"
+ "nisi ut aliquip ex ea commodo consequat. \n\n\n"
+ "Chapter 2\n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipisci\n"
+ "ng elit, sed do eiusmod tempor incididunt ut la\n"
+ "bore et dolore magna aliqua. Ut enim ad minim ve\n"
+ "niam, quis nostrud exercitation ullamco labo ris\n"
+ "nisi ut aliquip ex ea commodo consequat. \n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipisci\n"
+ "ng elit, sed do eiusmod tempor incididunt ut la\n"
+ "bore et dolore magna aliqua. Ut enim ad minim ve\n"
+ "niam, quis nostrud exercitation ullamco labo ris\n"
+ "nisi ut aliquip ex ea commodo consequat. ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}