import re
regex = re.compile(r"(?<=[a-zA-Z])(\n)", flags=re.MULTILINE)
test_str = ("Chapter 1\n\n"
"Lorem ipsum dolor sit amet, consectetur adipisci\n"
"ng elit, sed do eiusmod tempor incididunt ut la\n"
"bore et dolore magna aliqua. Ut enim ad minim ve\n"
"niam, quis nostrud exercitation ullamco labo ris\n"
"nisi ut aliquip ex ea commodo consequat. \n\n\n"
"Chapter 2\n\n"
"Lorem ipsum dolor sit amet, consectetur adipisci\n"
"ng elit, sed do eiusmod tempor incididunt ut la\n"
"bore et dolore magna aliqua. Ut enim ad minim ve\n"
"niam, quis nostrud exercitation ullamco labo ris\n"
"nisi ut aliquip ex ea commodo consequat. \n\n"
"Lorem ipsum dolor sit amet, consectetur adipisci\n"
"ng elit, sed do eiusmod tempor incididunt ut la\n"
"bore et dolore magna aliqua. Ut enim ad minim ve\n"
"niam, quis nostrud exercitation ullamco labo ris\n"
"nisi ut aliquip ex ea commodo consequat. ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)