#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "From:.+\r?\nSent:.+\r?\nTo:.+\r?\nSubject:.+"
Local $sString = "From: ***********************" & @CRLF & _
"Sent: ***********************" & @CRLF & _
"To: ***********************" & @CRLF & _
"Subject: *******************"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")