package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`From:.+\r?\nSent:.+\r?\nTo:.+\r?\nSubject:.+`)
var str = `From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}